MVP: Follow the naming convention used in Google's sample
Copied from https://www.reddit.com/r/androiddev/comments/5u3mix/how_is_your_mvp_naming_convention/ddrir2p/
Follow the naming convention used in Google's sample:
- [Feature]Contract.View - Interface for view
- [Feature]Contract.Presenter - Interface for presenter
- [Feature]Fragment - View implementation (yes, I'm not ashamed to use Fragments)
- [Feature]Presenter - Presenter implementation
- [Object]Model - Interface for Model
- [Object]Repository - Class that manages data from all sources
- Local[Object]Repository - Local source
- Remote[Object]Repository - Remote source